Activar sensores en Ubuntu [SOLUCIONADO]

Ver el tema anterior Ver el tema siguiente Ir abajo

Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  S3L3 el Lun Mayo 12 2008, 22:55

Estoy intentando activar los sensores para ver lo que se calienta el portatil, pero no me detecta ninguno, cosa que en el sobremesa si hace.
He instalado el lm-sensors segun la guia-ubuntu.
Imagino que habra que ponerlos a mano, pero estoy algo verde para eso, alguna idea?

S3L3

Cantidad de envíos : 47
Fecha de inscripción : 22/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  ciriaquitas el Lun Mayo 12 2008, 23:17

Instala sensors-applet y podras monotorizar la temperatura de la cpu con acpi, y la temperatura del disco duro si tambien instalas hddtemp.
Con lm-sensors yo tampoco he podido encontrar ningún sensor.

ciriaquitas

Cantidad de envíos : 60
Fecha de inscripción : 10/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  S3L3 el Lun Mayo 12 2008, 23:52

Se supone que para usar el sensor applet hay que instalar primero los sensors, o eso he leido en varios sitios, voy a probar.

S3L3

Cantidad de envíos : 47
Fecha de inscripción : 22/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  6izmo el Lun Mayo 12 2008, 23:59

No, no, el applet hace uso de los datos ACPI.


Código:
sudo apt-get install sensors-applet hddtemp

Luego en la barra de herramientas-> añadir al panel -> Monitor de sensores, y se puede configurar para que muestre la CPU y el disco duro.

Un saludo

6izmo

Cantidad de envíos : 86
Fecha de inscripción : 14/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  S3L3 el Mar Mayo 13 2008, 00:07

Ok, era lo que quiera, muchas gracias.

S3L3

Cantidad de envíos : 47
Fecha de inscripción : 22/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  Deimdos el Mar Mayo 13 2008, 00:43

Pues yo no he sido capaz de lograr ver la temperatura del disco duro en el applet (en la consola sí, pero es una forma muy rudimentaria). He probado eso que habeis puesto antes pero en ACPI solo me aparece la CPU... ¿alguna idea de lo que falla?

PD: tengo el AHCI activado.

Deimdos

Cantidad de envíos : 56
Fecha de inscripción : 11/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  ciriaquitas el Mar Mayo 13 2008, 01:03

Tienes que instalar hddtemp, arrancar el demonio, y en el applet marcar preferences/sensors/enabled.

ciriaquitas

Cantidad de envíos : 60
Fecha de inscripción : 10/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  S3L3 el Mar Mayo 13 2008, 01:16

Cuando instalas el applet te dice si quieres arrancar ese demonido del HDD siempre al inicio

S3L3

Cantidad de envíos : 47
Fecha de inscripción : 22/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  Sunami el Mar Mayo 13 2008, 17:35

Buen post y buena solucion 6izmo, ahí va otra chincheta...

Sunami
Admin

Cantidad de envíos : 55
Fecha de inscripción : 09/04/2008

Ver perfil de usuario http://vr201.bigforumpro.com

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  Deimdos el Mar Mayo 13 2008, 20:40

Pues sigue sin irme, yo cuando instalé el "sensors-applet" ya tenía instalado el HDDtemp (y veo la temperatura en la consola usando el comando "sudo hddtemp /dev/sda") pero no tengo ni idea de como hacer rular el demonio del hddtemp... he probado a añadirlo a inicio y nada, en los sensores solo me aparece el micro.

Por cierto, cuando instale tanto el hddtemp como el sensors-applet no me pregunto nada e añadirlo a inicio Neutral

Deimdos

Cantidad de envíos : 56
Fecha de inscripción : 11/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  kvi el Mar Mayo 13 2008, 21:07

Edita el fichero /etc/rc.local y antes de la última línea, es decir, antes de la línea "exit 0" insertas esta:
hddtemp -d /dev/sda
Salvas y reinicias, puedes probarlo antes desde el terminal y ver que se queda residente. La d de "-d" imagino que viene de Daemon
rc.local es un fichero donde podemos poner los comando que queremos que se ejecuten cada vez que iniciemos linux, en algunas distribuciones puede llamarse boot.local

kvi

Cantidad de envíos : 130
Fecha de inscripción : 11/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  Deimdos el Mar Mayo 13 2008, 23:46

kvi escribió:Edita el fichero /etc/rc.local y antes de la última línea, es decir, antes de la línea "exit 0" insertas esta:
hddtemp -d /dev/sda
Salvas y reinicias, puedes probarlo antes desde el terminal y ver que se queda residente. La d de "-d" imagino que viene de Daemon
rc.local es un fichero donde podemos poner los comando que queremos que se ejecuten cada vez que iniciemos linux, en algunas distribuciones puede llamarse boot.local
Gracias por lo de la "-d" Very Happy. Ahora ya tengo el daemon funcionando (lo he añadido de otro modo al inicio, mediante "sistema/preferencias/sesiones"), pero el sensors-applet ni se entera que existe el hddtemp Sad, sin embargo el applet de gnome de temperatura sí detecta al hddtemp aunque no muestra bien el valor, esto es un expediente X...

Deimdos

Cantidad de envíos : 56
Fecha de inscripción : 11/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  6izmo el Mar Mayo 13 2008, 23:59

Puede sonar a coña, pero ¿has probado a desinstalarlo y volverlo a instalar, así te debe salir otra vez el asistente y darle que sí?

Personalmente primero instalé el sensors-applet y al día siguiente el hddtemp. Para que el hddtemp saliera reflejado tuve que cerrar y abrir el applet.

Un saludo

6izmo

Cantidad de envíos : 86
Fecha de inscripción : 14/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  Deimdos el Miér Mayo 14 2008, 21:16

6izmo escribió:Puede sonar a coña, pero ¿has probado a desinstalarlo y volverlo a instalar, así te debe salir otra vez el asistente y darle que sí?

Personalmente primero instalé el sensors-applet y al día siguiente el hddtemp. Para que el hddtemp saliera reflejado tuve que cerrar y abrir el applet.

Un saludo
Las coñas muchas veces funcionan, como en este caso. Muchas gracias Wink

Deimdos

Cantidad de envíos : 56
Fecha de inscripción : 11/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  kvi el Miér Mayo 14 2008, 23:01

Si cargamos el módulo coretemp (con "sudo modprobe coretemp") podremos leer la temperatura directamente del diodo de la cpu.
Si queremos cargar ese módulo de forma automática debemos añadir en /etc/modules una línea conteniendo únicamente la palabra coretemp

kvi

Cantidad de envíos : 130
Fecha de inscripción : 11/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  ciriaquitas el Sáb Mayo 17 2008, 22:52

kvi escribió:Si cargamos el módulo coretemp (con "sudo modprobe coretemp") podremos leer la temperatura directamente del diodo de la cpu.
Si queremos cargar ese módulo de forma automática debemos añadir en /etc/modules una línea conteniendo únicamente la palabra coretemp

Muchas gracias. Tengo un compaq en el que ni con acpi ni con lm-sensors podia leer la temperatura, y esto funciona.

ciriaquitas

Cantidad de envíos : 60
Fecha de inscripción : 10/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  rcaba el Mar Sep 02 2008, 18:46

he instalao el sensors-applet y el hddtemp pero en añadir al pane no me viene monitor de temperaturas ni nada asi, si lo kiero volver a instalr me dice q ya esta instalado, como puedo ejecutarlo?

Saludos.

PD: He reiniciado y ya me aparece pero me marca 48 grados tanto la cpu como el hdd, excesiva cantidad no?

Que os marca a vosotros?

rcaba

Cantidad de envíos : 41
Fecha de inscripción : 16/08/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  ciriaquitas el Mar Sep 02 2008, 22:02

rcaba escribió:he instalao el sensors-applet y el hddtemp pero en añadir al pane no me viene monitor de temperaturas ni nada asi, si lo kiero volver a instalr me dice q ya esta instalado, como puedo ejecutarlo?

Saludos.

PD: He reiniciado y ya me aparece pero me marca 48 grados tanto la cpu como el hdd, excesiva cantidad no?

Que os marca a vosotros?

40 grados el disco duro y 46 la cpu en este momento, y lo único que hago es navegar.
Esta mañana, utilizando vitualbox la cpu llego a estar a más de 60 grados.
Acaban de subir el hdd a 46 y la cpu a 51. Supongo que algo influye el calor que hace hoy en bcn.

ciriaquitas

Cantidad de envíos : 60
Fecha de inscripción : 10/04/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  rcaba el Mar Sep 02 2008, 22:43

En el sur estamos q nos cocemos jeje, bien bien entonces no me preocupo, sq lo veia un poco excesivo comparado con mi sobremesa, aunq 48 el hd sin hacer practicamente nada me parece bastante, seguiré mirandolo aver como se van comportando.

Saludos.

rcaba

Cantidad de envíos : 41
Fecha de inscripción : 16/08/2008

Ver perfil de usuario

Volver arriba Ir abajo

Re: Activar sensores en Ubuntu [SOLUCIONADO]

Mensaje  Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.